<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<title>Hugo Patt is Content Being Deputy Prime Minister &#8211; Caribbean Edition</title>
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Feed" href="http://www.caribbeanedition.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Comments Feed" href="http://www.caribbeanedition.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Hugo Patt is Content Being Deputy Prime Minister Comments Feed" href="http://www.caribbeanedition.com/2020/02/14/hugo-patt-is-content-being-deputy-prime-minister/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.caribbeanedition.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='giornalismo-stylesheet-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/style.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-lato-css'  href='//fonts.googleapis.com/css?family=Lato%3A100%2C300%2C400%2C700&#038;ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald&#038;subset=latin%2Clatin-ext&#038;ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-roboto-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C300%2C700&#038;ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-quattrocento-css'  href='//fonts.googleapis.com/css?family=Quattrocento%3A700&#038;ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-mobile-css-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/css/mobile.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-tablet-css-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/css/tablet.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.caribbeanedition.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.caribbeanedition.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/themes/giornalismo/js/mobile-nav.js?ver=5.2.5'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/themes/giornalismo/js/mobile-sidebar.js?ver=5.2.5'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=59aedccf927254001127d777'></script>
<link rel='https://api.w.org/' href='http://www.caribbeanedition.com/wp-json/' />
<link rel='prev' title='A Renewed Call for Campaign Financing' href='http://www.caribbeanedition.com/2020/02/14/a-renewed-call-for-campaign-financing/' />
<link rel='next' title='Confesses to Receiving “Campaign Contributions” from Lev Dermen' href='http://www.caribbeanedition.com/2020/02/14/confesses-to-receiving-campaign-contributions-from-lev-dermen/' />
<meta name="generator" content="WordPress 5.2.5" />
<link rel='shortlink' href='http://www.caribbeanedition.com/?p=356599' />
<link rel="alternate" type="application/json+oembed" href="http://www.caribbeanedition.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.caribbeanedition.com%2F2020%2F02%2F14%2Fhugo-patt-is-content-being-deputy-prime-minister%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.caribbeanedition.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.caribbeanedition.com%2F2020%2F02%2F14%2Fhugo-patt-is-content-being-deputy-prime-minister%2F&#038;format=xml" />
<style type="text/css">
	#category-posts-2-internal .cat-post-item img {max-width: initial; max-height: initial; margin: initial;}
#category-posts-2-internal .cat-post-author {margin-bottom: 0;}
#category-posts-2-internal .cat-post-thumbnail {margin: 5px 10px 5px 0;}
#category-posts-2-internal .cat-post-item:before {content: ""; clear: both;}
#category-posts-2-internal .cat-post-title {font-size: 15px;}
#category-posts-2-internal .cat-post-current .cat-post-title {font-weight: bold; text-transform: uppercase;}
#category-posts-2-internal .cat-post-date {font-size: 14px; line-height: 18px; font-style: italic; margin-bottom: 5px;}
#category-posts-2-internal .cat-post-comment-num {font-size: 14px; line-height: 18px;}
#category-posts-2-internal .cat-post-item {border-bottom: 1px solid #ccc;	list-style: none; list-style-type: none; margin: 3px 0;	padding: 3px 0;}
#category-posts-2-internal .cat-post-item:last-child {border-bottom: none;}
#category-posts-2-internal .cat-post-item:after {content: ""; display: table;	clear: both;}
#category-posts-2-internal p {margin:5px 0 0 0}
#category-posts-2-internal li > div {margin:5px 0 0 0; clear:both;}
#category-posts-2-internal .dashicons {vertical-align:middle;}
#category-posts-2-internal .cat-post-crop {overflow: hidden; display:inline-block}
#category-posts-2-internal .cat-post-item img {margin: initial;}
#category-posts-2-internal .cat-post-thumbnail {float:left;}
</style>
	<meta http-equiv="Content-type" content="text/html; charset=utf-8" /><meta name="robots" content="noindex"><link rel='canonical' href='http://www.caribbeanedition.com/2020/02/14/hugo-patt-is-content-being-deputy-prime-minister/' />
		<style type="text/css" id="wp-custom-css">
			a {
    color: #0000FF;
}
a:hover, a:focus {
    color: #FF0000;
}
/* Redirect posts to original URL
add_action( 'template_redirect', 'nabm_original_post_redirect' );
function nabm_original_post_redirect() {
    if ( ! is_singular() ) {
        return;
    }
    if ( $url = giornalismo_get_custom_field( 'rss_pi_source_url' ) ) {
        wp_redirect( esc_url_raw( $url ), 301 );
        exit;
}		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
</head>
<body class="post-template-default single single-post postid-356599 single-format-standard">
			<!--Begin Top Menu-->
		<nav class="top-menu giornalismo-menu clearfix" role="navigation">
					</nav>
		<!--End Top Menu-->
		<!--Begin Mobile Nav-->
		<div class="mobile-nav-area">
			<a href="#" class="hide-show-mobile-nav">
				<div class="mobile-nav-bar">
					<div class="mobile-nav-icon"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/mobile-nav-icon.png" /></div>
					<h5>Go to ...</h5>
				</div>
			</a>
			<nav class="mobile-nav clearfix" role="navigation">
								<div class="mobile-nav-left">
									</div>
								<div class="mobile-nav-right" >
					<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-466" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466"><a href="http://www.caribbeanedition.com/about/">About</a></li>
<li id="menu-item-464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464"><a href="http://www.caribbeanedition.com/sources/">Sources</a></li>
<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="http://www.caribbeanedition.com/advertising/">Advertising</a></li>
<li id="menu-item-465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="http://www.caribbeanedition.com/contact/">Contact</a></li>
</ul></div>				</div>
			</nav>
		</div>
		<!--End Mobile Nav-->
	<header class="header-area clearfix">
		<!--Begin Masthead-->
		<section class="masthead"><h1 class="site-title"><a href="http://www.caribbeanedition.com">Caribbean Edition</a></h1><h2 class="site-description"><a href="http://www.caribbeanedition.com">Caribbean News Happens Fast</a></h2></section>		<!--End Masthead-->
		<!--Begin Header Right Area-->
		<section class="header-right">
								</section>
		<!--End Header Right Area-->
		<!--Begin Social Media Area-->
		<section class="social-area clearfix"><span class="twitter-social giornalismo-social-link"><a href="http://www.twitter.com/caribedition" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/twitter.png" width="40" /><span>Caribbean Edition on Twitter</span></a></span><span class="pinterest-social giornalismo-social-link"><a href="https://www.pinterest.com/caribedition/" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/pinterest.png" width="40" /><span>Caribbean Edition on Pinterest</span></a></span><span class="rss-social giornalismo-social-link"><a href="http://www.caribbeanedition.com/feed/rss/" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/rss.png" width="40" /><span>RSS Feed</span></a></span></section>		<!--End Social Media Area-->
			</header>
	<!--Begin Main Menu-->
	<nav class="main-menu giornalismo-menu clearfix" role="navigation">
		<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466"><a href="http://www.caribbeanedition.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464"><a href="http://www.caribbeanedition.com/sources/">Sources</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="http://www.caribbeanedition.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="http://www.caribbeanedition.com/contact/">Contact</a></li>
</ul></div>	</nav>
	<!--End Main Menu-->
	<!--Display Today's Date if Wanted-->
	<div class="todays-date"><h3>February 14, 2020</h3></div>	<div class="wrap"><section class="left-sidebar">
		</section>
<section class="right-sidebar">
	<div id="widget-wrap"><div class="widget-title"><h3>News Search</h3></div><p class="widget-body"><form role="search" method="get" id="searchform" class="searchform" action="http://www.caribbeanedition.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></p> </div><div id="widget-wrap"><div class="widget-title"><h3>Sponsored Link</h3></div><p class="widget-body">			<div class="textwidget"><a href="http://www.tkqlhce.com/5f108lnwtnvAJDFIHBEACBHEKIHHACFHEFCFFDCBBB" target="_blank" onmouseover="window.status='http://www.sandals.com';return true;" onmouseout="window.status=' ';return true;" rel="noopener noreferrer">
<img src="http://www.tqlkg.com/ap117jy1qwuFOIKNMGJFHGMJPNMMFHKMJKHKKIHGGG" alt="all inclusive caribbean" border="0"/></a></div>
		</p> </div>		<div id="widget-wrap">		<div class="widget-title"><h3>Latest Headlines</h3></div><p class="widget-body">		<ul>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/pride-on-top/">Pride on top</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/confesses-to-receiving-campaign-contributions-from-lev-dermen/">Confesses to Receiving “Campaign Contributions” from Lev Dermen</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/hugo-patt-is-content-being-deputy-prime-minister/">Hugo Patt is Content Being Deputy Prime Minister</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/a-renewed-call-for-campaign-financing/">A Renewed Call for Campaign Financing</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/will-patt-support-faber-for-party-leader/">Will Patt Support Faber for Party Leader?</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/patrick-faber-contemplates-a-second-candidacy/">Patrick Faber Contemplates a Second Candidacy</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/harding-puts-pride-back-on-top/">Harding puts Pride back on top</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/policereport-of-wednesday-february-12th-until-friday-february-14th-2020/">Policereport of Wednesday, February 12th until Friday, February 14th 2020</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/20-million-euros-for-the-caribbean-netherlands/">20 million euros for the Caribbean Netherlands</a>
											<span class="post-date">February 14, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/02/14/saint-lucia-police-get-report-writing-training/">Saint Lucia Police Get Report Writing Training</a>
											<span class="post-date">February 14, 2020</span>
									</li>
					</ul>
		</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Sponsored Link</h3></div><p class="widget-body">			<div class="textwidget"><p><a href="http://www.anrdoezrs.net/click-8367951-12186653" target="_top" rel="noopener noreferrer"><br />
<img src="http://www.awltovhc.com/image-8367951-12186653" width="300" height="250" alt="" border="0"/></a></p>
</div>
		</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Archives</h3></div><p class="widget-body">		<ul>
				<li><a href='http://www.caribbeanedition.com/2020/02/'>February 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2020/01/'>January 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/12/'>December 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/11/'>November 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/10/'>October 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/09/'>September 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/08/'>August 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/07/'>July 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/06/'>June 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/05/'>May 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/04/'>April 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/03/'>March 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/01/'>January 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2018/12/'>December 2018</a></li>
	<li><a href='http://www.caribbeanedition.com/2018/11/'>November 2018</a></li>
	<li><a href='http://www.caribbeanedition.com/2017/08/'>August 2017</a></li>
	<li><a href='http://www.caribbeanedition.com/1969/12/'>December 1969</a></li>
		</ul>
			</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Caribbean Countries</h3></div><p class="widget-body"><div class="menu-caribbean-countries-container"><ul id="menu-caribbean-countries" class="menu"><li id="menu-item-444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444"><a href="http://www.caribbeanedition.com/category/anguilla/">Anguilla</a></li>
<li id="menu-item-442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="http://www.caribbeanedition.com/category/antigua-and-barbuda/">Antigua and Barbuda</a></li>
<li id="menu-item-467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-467"><a href="http://www.caribbeanedition.com/category/aruba/">Aruba</a></li>
<li id="menu-item-443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="http://www.caribbeanedition.com/category/bahamas/">Bahamas</a></li>
<li id="menu-item-441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441"><a href="http://www.caribbeanedition.com/category/barbados/">Barbados</a></li>
<li id="menu-item-614" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-614"><a href="http://www.caribbeanedition.com/category/belize/">Belize</a></li>
<li id="menu-item-615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-615"><a href="http://www.caribbeanedition.com/category/bermuda/">Bermuda</a></li>
<li id="menu-item-616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-616"><a href="http://www.caribbeanedition.com/category/bonaire/">Bonaire</a></li>
<li id="menu-item-617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-617"><a href="http://www.caribbeanedition.com/category/british-virgin-islands/">British Virgin Islands</a></li>
<li id="menu-item-618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-618"><a href="http://www.caribbeanedition.com/category/caribbean/">Caribbean</a></li>
<li id="menu-item-619" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-619"><a href="http://www.caribbeanedition.com/category/cayman-islands/">Cayman Islands</a></li>
<li id="menu-item-620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-620"><a href="http://www.caribbeanedition.com/category/cuba/">Cuba</a></li>
<li id="menu-item-621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-621"><a href="http://www.caribbeanedition.com/category/curacao/">Curacao</a></li>
<li id="menu-item-622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-622"><a href="http://www.caribbeanedition.com/category/dominica/">Dominica</a></li>
<li id="menu-item-623" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-623"><a href="http://www.caribbeanedition.com/category/dominican-republic/">Dominican Republic</a></li>
<li id="menu-item-624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-624"><a href="http://www.caribbeanedition.com/category/grenada/">Grenada</a></li>
<li id="menu-item-625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-625"><a href="http://www.caribbeanedition.com/category/guadeloupe/">Guadeloupe</a></li>
<li id="menu-item-626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-626"><a href="http://www.caribbeanedition.com/category/guyana/">Guyana</a></li>
<li id="menu-item-627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-627"><a href="http://www.caribbeanedition.com/category/haiti/">Haiti</a></li>
<li id="menu-item-628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-628"><a href="http://www.caribbeanedition.com/category/jamaica/">Jamaica</a></li>
<li id="menu-item-629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-629"><a href="http://www.caribbeanedition.com/category/martinique/">Martinique</a></li>
<li id="menu-item-630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-630"><a href="http://www.caribbeanedition.com/category/montserrat/">Montserrat</a></li>
<li id="menu-item-631" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-631"><a href="http://www.caribbeanedition.com/category/puerto-rico/">Puerto Rico</a></li>
<li id="menu-item-632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-632"><a href="http://www.caribbeanedition.com/category/saba/">Saba</a></li>
<li id="menu-item-633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-633"><a href="http://www.caribbeanedition.com/category/st-barthelemy/">St. Barthelemy</a></li>
<li id="menu-item-634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-634"><a href="http://www.caribbeanedition.com/category/st-eustatius/">St. Eustatius</a></li>
<li id="menu-item-635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-635"><a href="http://www.caribbeanedition.com/category/st-kitts-nevis/">St. Kitts &#038; Nevis</a></li>
<li id="menu-item-636" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-636"><a href="http://www.caribbeanedition.com/category/st-lucia/">St. Lucia</a></li>
<li id="menu-item-637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-637"><a href="http://www.caribbeanedition.com/category/st-maarten-st-martin/">St. Maarten &#038; St. Martin</a></li>
<li id="menu-item-638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-638"><a href="http://www.caribbeanedition.com/category/st-vincent-the-grenadines/">St. Vincent &#038; the Grenadines</a></li>
<li id="menu-item-639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-639"><a href="http://www.caribbeanedition.com/category/suriname/">Suriname</a></li>
<li id="menu-item-640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-640"><a href="http://www.caribbeanedition.com/category/trinidad-and-tobago/">Trinidad and Tobago</a></li>
<li id="menu-item-641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-641"><a href="http://www.caribbeanedition.com/category/turks-and-caicos/">Turks and Caicos</a></li>
<li id="menu-item-642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-642"><a href="http://www.caribbeanedition.com/category/us-virgin-islands/">U.S. Virgin Islands</a></li>
</ul></div></p> </div><div id="widget-wrap"><div class="widget-title"><h3>Latest Caribbean News</h3></div><p class="widget-body"><ul id="category-posts-2-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-heartbreak-for-blackwood-but-scorpions-edge-ahead/" rel="bookmark">CRICKET-REGIONAL-LEAD Heartbreak for Blackwood but Scorpions edge ahead</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-heartbreak-for-blackwood-but-scorpions-edge-ahead/" title="CRICKET-REGIONAL-LEAD Heartbreak for Blackwood but Scorpions edge ahead"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-johnson-leads-jaguars-fightback-with-unbeaten-fifty/" rel="bookmark">CRICKET-REGIONAL-LEAD Johnson leads Jaguars fightback with unbeaten fifty</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-johnson-leads-jaguars-fightback-with-unbeaten-fifty/" title="CRICKET-REGIONAL-LEAD Johnson leads Jaguars fightback with unbeaten fifty"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-close-hurricanes-227-vs-scorpions-260-6-2nd-day-5th-round/" rel="bookmark">CRICKET-REGIONAL-CLOSE Hurricanes (227) vs Scorpions 260-6 – 2nd day, 5th round</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-close-hurricanes-227-vs-scorpions-260-6-2nd-day-5th-round/" title="CRICKET-REGIONAL-CLOSE Hurricanes (227) vs Scorpions 260-6 – 2nd day, 5th round"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-red-force-left-staggering-after-harding-five-fer-brathwaite-fifty/" rel="bookmark">CRICKET-REGIONAL-LEAD Red Force left staggering after Harding five-fer, Brathwaite fifty</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-lead-red-force-left-staggering-after-harding-five-fer-brathwaite-fifty/" title="CRICKET-REGIONAL-LEAD Red Force left staggering after Harding five-fer, Brathwaite fifty"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-close-volcanoes-318-vs-jaguars-145-3-2nd-day-5th-round/" rel="bookmark">CRICKET-REGIONAL-CLOSE Volcanoes (318) vs Jaguars 145-3 – 2nd day, 5th round</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cricket-regional-close-volcanoes-318-vs-jaguars-145-3-2nd-day-5th-round/" title="CRICKET-REGIONAL-CLOSE Volcanoes (318) vs Jaguars 145-3 – 2nd day, 5th round"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/antigua-chosen-as-location-for-royal-caribbean-cruise-lines-first-royal-beach-club/" rel="bookmark">Antigua Chosen as Location for Royal Caribbean Cruise Line’s First Royal Beach Club</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/antigua-chosen-as-location-for-royal-caribbean-cruise-lines-first-royal-beach-club/" title="Antigua Chosen as Location for Royal Caribbean Cruise Line’s First Royal Beach Club"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/cayman-islands-awaits-official-word-amid-reports-its-being-placed-on-eu-blacklist-of-tax-havens/" rel="bookmark">Cayman Islands Awaits Official Word Amid Reports It’s Being Placed on EU Blacklist of Tax Havens</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/cayman-islands-awaits-official-word-amid-reports-its-being-placed-on-eu-blacklist-of-tax-havens/" title="Cayman Islands Awaits Official Word Amid Reports It’s Being Placed on EU Blacklist of Tax Havens"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/haiti-crime-authorities-concerned-at-significant-increase-in-kidnappings/" rel="bookmark">HAITI-CRIME-Authorities concerned at significant increase in kidnappings</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/haiti-crime-authorities-concerned-at-significant-increase-in-kidnappings/" title="HAITI-CRIME-Authorities concerned at significant increase in kidnappings"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/guyana-politics-ruling-coalition-unveils-very-ambitious-manifesto/" rel="bookmark">GUYANA-POLITICS-Ruling coalition unveils “very ambitious” manifesto</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/guyana-politics-ruling-coalition-unveils-very-ambitious-manifesto/" title="GUYANA-POLITICS-Ruling coalition unveils “very ambitious” manifesto"></a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/02/14/antigua-politics-eu-delegation-hold-talks-with-government/" rel="bookmark">ANTIGUA-POLITICS-EU delegation hold talks with government</a></div><div><span class="cat-post-date">14 Feb 2020</span></div><div><a class="cat-post-thumbnail cat-post-none" href="http://www.caribbeanedition.com/2020/02/14/antigua-politics-eu-delegation-hold-talks-with-government/" title="ANTIGUA-POLITICS-EU delegation hold talks with government"></a></div></li></ul>
</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Sponsored Link</h3></div><p class="widget-body">			<div class="textwidget"><a href="http://www.dpbolvw.net/gp70cy63y5LUOQTSMPLNNNNPTRTLNQSPQNQQONMMM" target="_blank" onmouseover="window.status='http://www.sandals.com';return true;" onmouseout="window.status=' ';return true;" rel="noopener noreferrer">
<img src="http://www.lduhtrp.net/6k115r6Az42OXRTWVPSOQQQQSWUWOQTVSTQTTRQPPP" alt="" border="0"/></a></div>
		</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Website Policies</h3></div><p class="widget-body"><div class="menu-website-policies-container"><ul id="menu-website-policies" class="menu"><li id="menu-item-402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-402"><a href="http://www.caribbeanedition.com/affiliate-disclaimer/">Affiliate Disclaimer</a></li>
<li id="menu-item-116489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116489"><a href="http://www.caribbeanedition.com/general-disclaimer/">General Disclaimer</a></li>
<li id="menu-item-403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-403"><a href="http://www.caribbeanedition.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401"><a href="http://www.caribbeanedition.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul></div></p> </div></section>	<main class="post-single">
				<article id="356599" class="single-story post-356599 post type-post status-publish format-standard hentry category-belize">
												<header class="story-header">
				<h3 class="headline">Hugo Patt is Content Being Deputy Prime Minister</h3>
				<h5 class="byline">February 14, 2020</h5>
			</header>
			<hr />
			<!--Grab the story lines if there are any-->
						<p>Source: Channel 5 Belize</p>
<p>In four short days, the internal chaos in the Barrow administration and the United Democratic Party has brought embarrassment and humiliation.   With the resignation of&hellip;</p>
<p>Link: <a href="https://edition.channel5belize.com/archives/198449" target="_blank" rel="nofollow noopener noreferrer" rel="nofollow" >Hugo Patt is Content Being Deputy Prime Minister</a></p>
            			<p class="tags"></p>
		</article>
				<!--Get the comments template-->
		<section class="comments-area">
						<!-- If comments are closed. -->
			</section>
		<!--Get the related stories-->
				<!--Get the latest stories in the category-->
		<section class="latest-category clearfix"><h3 class="title">More Stories From Belize</h3><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/02/14/confesses-to-receiving-campaign-contributions-from-lev-dermen/">Confesses to Receiving “Campaign Contributions” from Lev Dermen</a></h5></article><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/02/14/a-renewed-call-for-campaign-financing/">A Renewed Call for Campaign Financing</a></h5></article><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/02/14/will-patt-support-faber-for-party-leader/">Will Patt Support Faber for Party Leader?</a></h5></article></section>		<!--Get the author bio-->
			</main> 
<!--Begin Mobile Sidebar-->
<section class="mobile-sidebar">
</section>
<!--End Mobile Sidebar-->
</div><!--End Wrap-->
<footer class="footer">
	<p><a href="http://www.caribbeanedition.com">Caribbean Edition</a> | <a href="https://jacobmartella.com/wordpress/wordpress-themes/giornalismo-wordpress-theme/" target="_blank">Giornalismo</a> | Copyright  &copy;2020 | <a href="http://www.caribbeanedition.com/wp-login.php?itsec-hb-token=wplogin">Log in</a></p>
</footer>
<script>
    jQuery(document).ready(function () {
		jQuery.post('http://www.caribbeanedition.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/comment-reply.min.js?ver=5.2.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.caribbeanedition.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/blankshield/blankshield.min.js?ver=4113'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/block-tabnapping.min.js?ver=4113'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/wp-embed.min.js?ver=5.2.5'></script>
</body>
</html>

<!-- Cache Enabler by KeyCDN @ 14.02.2020 23:32:53 (html) -->