<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	<title>Community cops nab suspect coke dealer &#8211; Caribbean Edition</title>
<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Feed" href="http://www.caribbeanedition.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Comments Feed" href="http://www.caribbeanedition.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Caribbean Edition &raquo; Community cops nab suspect coke dealer Comments Feed" href="http://www.caribbeanedition.com/2020/05/02/community-cops-nab-suspect-coke-dealer/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.caribbeanedition.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- caribbeanedition.com is managing ads with Advanced Ads --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='giornalismo-stylesheet-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/style.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-lato-css'  href='//fonts.googleapis.com/css?family=Lato%3A100%2C300%2C400%2C700&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald&#038;subset=latin%2Clatin-ext&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-roboto-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C300%2C700&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-quattrocento-css'  href='//fonts.googleapis.com/css?family=Quattrocento%3A700&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-mobile-css-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/css/mobile.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='giornalismo-tablet-css-css'  href='http://www.caribbeanedition.com/wp-content/themes/giornalismo/css/tablet.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.caribbeanedition.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.caribbeanedition.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.7' type='text/css' media='all' />
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/themes/giornalismo/js/mobile-nav.js?ver=5.4.1'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/themes/giornalismo/js/mobile-sidebar.js?ver=5.4.1'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=59aedccf927254001127d777'></script>
<link rel='https://api.w.org/' href='http://www.caribbeanedition.com/wp-json/' />
<link rel='prev' title='Covid-19 Still Active on our Shores' href='http://www.caribbeanedition.com/2020/05/02/covid-19-still-active-on-our-shores/' />
<link rel='next' title='PM CHASTANET DELIVERS $1.697 BILLION BUDGET AS PIERRE HAMMERS GOVERNMENT' href='http://www.caribbeanedition.com/2020/05/02/pm-chastanet-delivers-1-697-billion-budget-as-pierre-hammers-government/' />
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='http://www.caribbeanedition.com/?p=378547' />
<link rel="alternate" type="application/json+oembed" href="http://www.caribbeanedition.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.caribbeanedition.com%2F2020%2F05%2F02%2Fcommunity-cops-nab-suspect-coke-dealer%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.caribbeanedition.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.caribbeanedition.com%2F2020%2F05%2F02%2Fcommunity-cops-nab-suspect-coke-dealer%2F&#038;format=xml" />
<style>
	#category-posts-2-internal ul {padding: 0;}
#category-posts-2-internal .cat-post-item img {max-width: initial; max-height: initial; margin: initial;}
#category-posts-2-internal .cat-post-author {margin-bottom: 0;}
#category-posts-2-internal .cat-post-thumbnail {margin: 5px 10px 5px 0;}
#category-posts-2-internal .cat-post-item:before {content: ""; clear: both;}
#category-posts-2-internal .cat-post-title {font-size: 15px;}
#category-posts-2-internal .cat-post-current .cat-post-title {font-weight: bold; text-transform: uppercase;}
#category-posts-2-internal .cat-post-date {font-size: 14px; line-height: 18px; font-style: italic; margin-bottom: 5px;}
#category-posts-2-internal .cat-post-comment-num {font-size: 14px; line-height: 18px;}
#category-posts-2-internal .cat-post-item {border-bottom: 1px solid #ccc;	list-style: none; list-style-type: none; margin: 3px 0;	padding: 3px 0;}
#category-posts-2-internal .cat-post-item:last-child {border-bottom: none;}
#category-posts-2-internal .cat-post-item:after {content: ""; display: table;	clear: both;}
#category-posts-2-internal p {margin:5px 0 0 0}
#category-posts-2-internal li > div {margin:5px 0 0 0; clear:both;}
#category-posts-2-internal .dashicons {vertical-align:middle;}
#category-posts-2-internal .cat-post-thumbnail .cat-post-crop img {width: 25px;}
#category-posts-2-internal .cat-post-thumbnail .cat-post-crop img {height: 25px;}
#category-posts-2-internal .cat-post-thumbnail .cat-post-crop img {object-fit: cover;max-width:100%;}
#category-posts-2-internal .cat-post-thumbnail .cat-post-crop-not-supported img {width:100%;}
#category-posts-2-internal .cat-post-thumbnail {max-width:100%;}
#category-posts-2-internal .cat-post-item img {margin: initial;}
#category-posts-2-internal .cat-post-thumbnail {float:left;}
</style>
	<meta http-equiv="Content-type" content="text/html; charset=utf-8" /><meta name="robots" content="noindex"><link rel='canonical' href='http://www.caribbeanedition.com/2020/05/02/community-cops-nab-suspect-coke-dealer/' />
		<style type="text/css" id="wp-custom-css">
			a {
    color: #0000FF;
}
a:hover, a:focus {
    color: #FF0000;
}
/* Redirect posts to original URL
add_action( 'template_redirect', 'nabm_original_post_redirect' );
function nabm_original_post_redirect() {
    if ( ! is_singular() ) {
        return;
    }
    if ( $url = giornalismo_get_custom_field( 'rss_pi_source_url' ) ) {
        wp_redirect( esc_url_raw( $url ), 301 );
        exit;
}		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
</head>
<body class="post-template-default single single-post postid-378547 single-format-standard">
			<!--Begin Top Menu-->
		<nav class="top-menu giornalismo-menu clearfix" role="navigation">
					</nav>
		<!--End Top Menu-->
		<!--Begin Mobile Nav-->
		<div class="mobile-nav-area">
			<a href="#" class="hide-show-mobile-nav">
				<div class="mobile-nav-bar">
					<div class="mobile-nav-icon"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/mobile-nav-icon.png" /></div>
					<h5>Go to ...</h5>
				</div>
			</a>
			<nav class="mobile-nav clearfix" role="navigation">
								<div class="mobile-nav-left">
									</div>
								<div class="mobile-nav-right" >
					<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-466" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466"><a href="http://www.caribbeanedition.com/about/">About</a></li>
<li id="menu-item-464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464"><a href="http://www.caribbeanedition.com/sources/">Sources</a></li>
<li id="menu-item-757" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="http://www.caribbeanedition.com/advertising/">Advertising</a></li>
<li id="menu-item-465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="http://www.caribbeanedition.com/contact/">Contact</a></li>
</ul></div>				</div>
			</nav>
		</div>
		<!--End Mobile Nav-->
	<header class="header-area clearfix">
		<!--Begin Masthead-->
		<section class="masthead"><h1 class="site-title"><a href="http://www.caribbeanedition.com">Caribbean Edition</a></h1><h2 class="site-description"><a href="http://www.caribbeanedition.com">Caribbean News Happens Fast</a></h2></section>		<!--End Masthead-->
		<!--Begin Header Right Area-->
		<section class="header-right">
								</section>
		<!--End Header Right Area-->
		<!--Begin Social Media Area-->
		<section class="social-area clearfix"><span class="twitter-social giornalismo-social-link"><a href="http://www.twitter.com/caribedition" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/twitter.png" width="40" /><span>Caribbean Edition on Twitter</span></a></span><span class="pinterest-social giornalismo-social-link"><a href="https://www.pinterest.com/caribedition/" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/pinterest.png" width="40" /><span>Caribbean Edition on Pinterest</span></a></span><span class="rss-social giornalismo-social-link"><a href="http://www.caribbeanedition.com/feed/rss/" target="_blank"><img src="http://www.caribbeanedition.com/wp-content/themes/giornalismo/images/rss.png" width="40" /><span>RSS Feed</span></a></span></section>		<!--End Social Media Area-->
			</header>
	<!--Begin Main Menu-->
	<nav class="main-menu giornalismo-menu clearfix" role="navigation">
		<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-466"><a href="http://www.caribbeanedition.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-464"><a href="http://www.caribbeanedition.com/sources/">Sources</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-757"><a href="http://www.caribbeanedition.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="http://www.caribbeanedition.com/contact/">Contact</a></li>
</ul></div>	</nav>
	<!--End Main Menu-->
	<!--Display Today's Date if Wanted-->
	<div class="todays-date"><h3>May 2, 2020</h3></div>	<div class="wrap"><section class="left-sidebar">
		</section>
<section class="right-sidebar">
	<div id="widget-wrap"><div class="widget-title"><h3>News Search</h3></div><p class="widget-body"><form role="search" method="get" id="searchform" class="searchform" action="http://www.caribbeanedition.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></p> </div>		<div id="widget-wrap">		<div class="widget-title"><h3>Latest Headlines</h3></div><p class="widget-body">		<ul>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/challenges-new-opportunities-to-continue-to-build-a-stronger-saint-lucia-together/">CHALLENGES: NEW OPPORTUNITIES TO CONTINUE TO BUILD A STRONGER  SAINT LUCIA TOGETHER</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/hopes-dim-for-early-re-opening-of-economy-even-as-more-businesses-open-their-doors/">Hopes Dim for Early Re-Opening of Economy  Even as More Businesses Open Their Doors</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/caribbean-rights-jamaican-diplomat-on-free-expression-rapporteur-shortlist/">CARIBBEAN-RIGHTS-Jamaican diplomat on free expression rapporteur shortlist</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/trinidad-pm-denies-breaking-us-sanctions/">Trinidad PM denies breaking US sanctions</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/haiti-paho-who-donation-of-a-second-batch-of-it-equipment-to-the-director-of-west-health/">Haiti &#8211; PAHO / WHO : Donation of a second batch of IT equipment to the Director of West Health</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/pm-chastanet-delivers-1-697-billion-budget-as-pierre-hammers-government/">PM CHASTANET DELIVERS $1.697 BILLION BUDGET AS PIERRE HAMMERS GOVERNMENT</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/community-cops-nab-suspect-coke-dealer/" aria-current="page">Community cops nab suspect coke dealer</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/covid-19-still-active-on-our-shores/">Covid-19 Still Active on our Shores</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/rental-grant-for-landlords-not-applicants/">Rental grant for landlords, not applicants</a>
											<span class="post-date">May 2, 2020</span>
									</li>
											<li>
					<a href="http://www.caribbeanedition.com/2020/05/02/water-is-life/">Water is Life</a>
											<span class="post-date">May 2, 2020</span>
									</li>
					</ul>
		</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Archives</h3></div><p class="widget-body">		<ul>
				<li><a href='http://www.caribbeanedition.com/2020/05/'>May 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2020/04/'>April 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2020/03/'>March 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2020/02/'>February 2020</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/12/'>December 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2019/06/'>June 2019</a></li>
	<li><a href='http://www.caribbeanedition.com/2018/12/'>December 2018</a></li>
	<li><a href='http://www.caribbeanedition.com/1969/12/'>December 1969</a></li>
		</ul>
			</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Caribbean Countries</h3></div><p class="widget-body"><div class="menu-caribbean-countries-container"><ul id="menu-caribbean-countries" class="menu"><li id="menu-item-444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-444"><a href="http://www.caribbeanedition.com/category/anguilla/">Anguilla</a></li>
<li id="menu-item-442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-442"><a href="http://www.caribbeanedition.com/category/antigua-and-barbuda/">Antigua and Barbuda</a></li>
<li id="menu-item-467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-467"><a href="http://www.caribbeanedition.com/category/aruba/">Aruba</a></li>
<li id="menu-item-443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-443"><a href="http://www.caribbeanedition.com/category/bahamas/">Bahamas</a></li>
<li id="menu-item-441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-441"><a href="http://www.caribbeanedition.com/category/barbados/">Barbados</a></li>
<li id="menu-item-614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-614"><a href="http://www.caribbeanedition.com/category/belize/">Belize</a></li>
<li id="menu-item-615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-615"><a href="http://www.caribbeanedition.com/category/bermuda/">Bermuda</a></li>
<li id="menu-item-616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-616"><a href="http://www.caribbeanedition.com/category/bonaire/">Bonaire</a></li>
<li id="menu-item-617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-617"><a href="http://www.caribbeanedition.com/category/british-virgin-islands/">British Virgin Islands</a></li>
<li id="menu-item-618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-618"><a href="http://www.caribbeanedition.com/category/caribbean/">Caribbean</a></li>
<li id="menu-item-619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-619"><a href="http://www.caribbeanedition.com/category/cayman-islands/">Cayman Islands</a></li>
<li id="menu-item-620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-620"><a href="http://www.caribbeanedition.com/category/cuba/">Cuba</a></li>
<li id="menu-item-621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-621"><a href="http://www.caribbeanedition.com/category/curacao/">Curacao</a></li>
<li id="menu-item-622" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-622"><a href="http://www.caribbeanedition.com/category/dominica/">Dominica</a></li>
<li id="menu-item-623" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-623"><a href="http://www.caribbeanedition.com/category/dominican-republic/">Dominican Republic</a></li>
<li id="menu-item-624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-624"><a href="http://www.caribbeanedition.com/category/grenada/">Grenada</a></li>
<li id="menu-item-625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-625"><a href="http://www.caribbeanedition.com/category/guadeloupe/">Guadeloupe</a></li>
<li id="menu-item-626" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-626"><a href="http://www.caribbeanedition.com/category/guyana/">Guyana</a></li>
<li id="menu-item-627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-627"><a href="http://www.caribbeanedition.com/category/haiti/">Haiti</a></li>
<li id="menu-item-628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-628"><a href="http://www.caribbeanedition.com/category/jamaica/">Jamaica</a></li>
<li id="menu-item-629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-629"><a href="http://www.caribbeanedition.com/category/martinique/">Martinique</a></li>
<li id="menu-item-630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-630"><a href="http://www.caribbeanedition.com/category/montserrat/">Montserrat</a></li>
<li id="menu-item-631" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-631"><a href="http://www.caribbeanedition.com/category/puerto-rico/">Puerto Rico</a></li>
<li id="menu-item-632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-632"><a href="http://www.caribbeanedition.com/category/saba/">Saba</a></li>
<li id="menu-item-633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-633"><a href="http://www.caribbeanedition.com/category/st-barthelemy/">St. Barthelemy</a></li>
<li id="menu-item-634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-634"><a href="http://www.caribbeanedition.com/category/st-eustatius/">St. Eustatius</a></li>
<li id="menu-item-635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-635"><a href="http://www.caribbeanedition.com/category/st-kitts-nevis/">St. Kitts &#038; Nevis</a></li>
<li id="menu-item-636" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-636"><a href="http://www.caribbeanedition.com/category/st-lucia/">St. Lucia</a></li>
<li id="menu-item-637" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-637"><a href="http://www.caribbeanedition.com/category/st-maarten-st-martin/">St. Maarten &#038; St. Martin</a></li>
<li id="menu-item-638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-638"><a href="http://www.caribbeanedition.com/category/st-vincent-the-grenadines/">St. Vincent &#038; the Grenadines</a></li>
<li id="menu-item-639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-639"><a href="http://www.caribbeanedition.com/category/suriname/">Suriname</a></li>
<li id="menu-item-640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-640"><a href="http://www.caribbeanedition.com/category/trinidad-and-tobago/">Trinidad and Tobago</a></li>
<li id="menu-item-641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-641"><a href="http://www.caribbeanedition.com/category/turks-and-caicos/">Turks and Caicos</a></li>
<li id="menu-item-642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-642"><a href="http://www.caribbeanedition.com/category/us-virgin-islands/">U.S. Virgin Islands</a></li>
</ul></div></p> </div><div id="widget-wrap"><div class="widget-title"><h3>Latest Caribbean News</h3></div><p class="widget-body"><ul id="category-posts-2-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/02/caribbean-rights-jamaican-diplomat-on-free-expression-rapporteur-shortlist/" rel="bookmark">CARIBBEAN-RIGHTS-Jamaican diplomat on free expression rapporteur shortlist</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/02/bermuda-health-political-rivals-show-united-front-in-fight-against-killer-virus/" rel="bookmark">BERMUDA-HEALTH-Political rivals show united front in fight against killer virus</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/02/jamaica-health-government-denies-demanding-payment-for-repatriation-of-nationals-stranded-overseas/" rel="bookmark">JAMAICA-HEALTH-Government denies demanding payment for repatriation of nationals stranded overseas</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/02/jamaica-health-jamaican-parents-warned-to-safeguard-children-against-injecting-disinfectants/" rel="bookmark">JAMAICA-HEALTH-Jamaican parents warned to safeguard children against injecting disinfectants</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/02/grenada-health-grenada-praises-cubas-assistance-in-dealing-with-covid-19/" rel="bookmark">GRENADA-HEALTH-Grenada praises Cuba’s assistance in dealing with COVID-19</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/01/cricket-health-dujon-foresees-write-off-in-2020-sporting-calendar/" rel="bookmark">CRICKET-HEALTH-Dujon foresees write-off in 2020 sporting calendar</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/01/cricket-windies-pooran-a-great-option-for-tests-says-bravo/" rel="bookmark">CRICKET-WINDIES-Pooran a great option for Tests, says Bravo</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/01/guyana-finance-guyana-deposits-first-royalty-payment-from-its-oil-sector/" rel="bookmark">GUYANA-FINANCE-Guyana deposits first royalty payment from its oil sector</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/01/update-guyana-politics-caricom-calls-for-transparent-recount-process-as-high-level-team-arrives/" rel="bookmark">UPDATE-GUYANA-POLITICS-CARICOM calls for transparent recount process as high level team arrives</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="http://www.caribbeanedition.com/2020/05/01/antigua-finance-antigua-pm-apologies-to-opposition-leader-urges-him-to-be-part-of-economic-recovery-committee/" rel="bookmark">ANTIGUA-FINANCE-Antigua PM apologies to Opposition Leader, urges him to be part of Economic Recovery Committee</a></div></li></ul>
</p> </div><div id="widget-wrap"><div class="widget-title"><h3>Website Policies</h3></div><p class="widget-body"><div class="menu-website-policies-container"><ul id="menu-website-policies" class="menu"><li id="menu-item-402" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-402"><a href="http://www.caribbeanedition.com/affiliate-disclaimer/">Affiliate Disclaimer</a></li>
<li id="menu-item-116489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-116489"><a href="http://www.caribbeanedition.com/general-disclaimer/">General Disclaimer</a></li>
<li id="menu-item-403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-403"><a href="http://www.caribbeanedition.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-401"><a href="http://www.caribbeanedition.com/terms-and-conditions/">Terms and Conditions</a></li>
</ul></div></p> </div></section>	<main class="post-single">
		<ul class="breadcrumbs"><li><a href="http://www.caribbeanedition.com">Home</a></li><li class="breadcrumbs-active .category-cayman-islands"><a href="/index.php?cat=45">Cayman Islands</a></li><li class="breadcrumbs-active .category-cayman-islands">Community cops nab suspect coke dealer</li></ul>		<article id="378547" class="single-story post-378547 post type-post status-publish format-standard hentry category-cayman-islands">
												<header class="story-header">
				<h3 class="headline">Community cops nab suspect coke dealer</h3>
				<h5 class="byline">May 2, 2020</h5>
			</header>
			<hr />
			<!--Grab the story lines if there are any-->
						<p>Source: Cayman News Service</p>
<p>(CNS): A 52-year-old man from George Town has been arrested for drug dealing after he raised the suspicions of community beat officers on patrol in&hellip;</p>
<p>Link: <a href="https://caymannewsservice.com/2020/05/community-cops-nab-suspect-coke-dealer/" target="_blank" rel="nofollow noopener noreferrer" rel="nofollow" >Community cops nab suspect coke dealer</a></p>
            			<p class="tags"></p>
		</article>
				<!--Get the comments template-->
		<section class="comments-area">
						<!-- If comments are closed. -->
			</section>
		<!--Get the related stories-->
				<!--Get the latest stories in the category-->
		<section class="latest-category clearfix"><h3 class="title">More Stories From Cayman Islands</h3><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/05/01/new-curfew-opens-up-mixed-bag-of-access/">New curfew opens up mixed bag of access</a></h5></article><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/05/01/local-positive-mars-stack-of-negative-tests/">Local positive mars stack of negative tests</a></h5></article><article class="story"><h5 class="headline"><a href="http://www.caribbeanedition.com/2020/05/01/1000s-of-ppe-kits-and-test-swabs-arrive/">1,000s of PPE kits and test swabs arrive</a></h5></article></section>		<!--Get the author bio-->
			</main> 
<!--Begin Mobile Sidebar-->
<section class="mobile-sidebar">
</section>
<!--End Mobile Sidebar-->
</div><!--End Wrap-->
<footer class="footer">
	<p><a href="http://www.caribbeanedition.com">Caribbean Edition</a> | <a href="https://jacobmartella.com/wordpress/wordpress-themes/giornalismo-wordpress-theme/" target="_blank">Giornalismo</a> | Copyright  &copy;2020 | <a href="http://www.caribbeanedition.com/wp-login.php?itsec-hb-token=wplogin">Log in</a></p>
</footer>
<script>
    jQuery(document).ready(function () {
		jQuery.post('http://www.caribbeanedition.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script>"undefined"!=typeof jQuery&&jQuery(document).ready(function(){"objectFit"in document.documentElement.style==!1&&(jQuery(".cat-post-item figure").removeClass("cat-post-crop"),jQuery(".cat-post-item figure").addClass("cat-post-crop-not-supported")),(document.documentMode||/Edge/.test(navigator.userAgent))&&(jQuery(".cat-post-item figure img").height("+=1"),window.setTimeout(function(){jQuery(".cat-post-item figure img").height("-=1")},0))});</script><script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.caribbeanedition.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.7'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/blankshield/blankshield.min.js?ver=4118'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-content/plugins/better-wp-security/core/modules/wordpress-tweaks/js/block-tabnapping.min.js?ver=4118'></script>
<script type='text/javascript' src='http://www.caribbeanedition.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
</body>
</html>

<!-- Cache Enabler by KeyCDN @ 02.05.2020 12:02:19 (html) -->